PeopleTools 8.50 Application has failed to start because the application configuration is incorrect.


After installing the PT 8.50.01, all Windows client PeopleTools applications fail to start and errors with the following.

ERROR
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This application has failed to start because the application configuration is incorrect.  Reinstalling the application may fix this problem.

STEPS
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The issue can be reproduced with the following steps:
1. Start any Windows client PeopleTools application such as Configuration Manager, Application Designer, or Data Mover.

Cause

In the PeopleTools 8.50 Installation guide, the task titled "Verifying Necessary Files for Installation on Windows"  explains that the issue is caused by the C Run Time (CRT) files not getting updated which will cause PeopleTools not to run.
From the PeopleTools 8.50 Installation guide Task "Verifying Necessary Files for Installation on Windows":
PeopleSoft PeopleTools 8.50 is developed using Microsoft Visual C++ 2005. Microsoft, as part of VC++ 2005, changed the way applications use and ship the required C Run Time (CRT) files (these files are installed as shared assemblies). PeopleSoft PeopleTools 8.50 programs require these files to be present or the programs will not run.

During your PeopleSoft PeopleTools installation, the install programs will automatically update the Microsoft Windows machine performing the installation.

The required CRT files are installed by all of the PeopleSoft installers, including:
o - PeopleSoft PeopleTools (including: Application Designer, Data Mover, Configuration Manager).
o - Database
o - PeopleSoft Pure Internet Architecture
o - Change Assistant PeopleSoft Installer
o - Change Impact Analyzer
o - Web app Deploy

In some cases it may be necessary for you to carry out a separate installation of the CRT files. For example:
o - If the update does not take place during the installation program run, you may not be able to launch PeopleSoft PeopleTools client or server executables on that machine and may receive error messages.
o - If you are accessing PeopleSoft PeopleTools executables from a machine on which the PeopleSoft installer did not run, the executables may not work and you may receive error messages.

Solution

To implement the solution, execute the following steps:

1. Go to PS_HOME\setup\vcredist.
2. Run vcredist_x86.exe.
The installation is completed automatically.
3. Test by starting any Windows client PeopleTools application such as Configuration Manager, Application Designer, or Data Mover.