Peoplecode error when logging in for a new demo install for Enterprise Portal 9.0, PT8.50.xx

Peoplecode error when logging in for a new demo install for Enterprise Portal 9.0, PT8.50.xx


Enterprise Portal 9.0, PeopleTools (PT) 8.50.01, Install and Packaging

The demo install of Portal Solutions 9.0 on PT 8.50.01 has completed.
When trying to login through PIA, we get the following error:
ERROR
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alert('PeopleCode compile error (Method GetUniHeaderHTML parameter 2 differs from superclass None. (2,86)) for program EPPBR_BRANDING.RoleBasedBranding.OnExecute. (2,405)\n\nA PeopleCode program for the specified reference failed to compile correctly for the indicated reason. \n\nIn Application Designer, open the referenced program and examine the PeopleCode to locate the cause of the error.');Class EPPBR_BRANDING:RoleBasedBranding was not found. (180,74) WEBLIB_PORTAL.PORTAL_HEADER.FieldFormula Name:CreateBrandingObject PCPC:4903 Statement:85 Called from:WEBLIB_PT_NAV.ISCRIPT1.FieldFormula Name:buildIframeTemplate Statement:98 Called from:WEBLIB_PT_NAV.ISCRIPT1.FieldFormula Name:IScript_PT_NAV_TPL_FRAME Statement:124


STEPS
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The issue can be reproduced with the following steps:
1. Complete the installation for PeopleTools 8.50.xx
    and Enterprise Portal 9.0 as outlined in the Installation guides.
2. Launch the PIA signon page.
3. Signon to the application.


BUSINESS IMPACT
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The issue has the following business impact:
Due to this issue, users cannot signon to the application successfully.


Cause

The issue is caused by the following setup: Setup that is incorrect.
Enterprise Portal (EP) 9.0 is not Generally Available on 8.50.
In order to use it on PeopleTools 8.50, a user has to run the PeopleTools Only Upgrade and then apply 2 Update IDs 810689 & 811680.
For an install/upgrade of EP9 to PeopleTools 8.50, these patches are required.

Solution

Workaround (until PeopleTools 8.50 Upgrade Availability is available)
Install Enterprise Portal 9.1 (instead of Enterprise Portal 9.1) with PeopleTools 8.50.xx, until PeopleTools 8.50 Upgrade Availability is announced/available.

To implement the workaround/solution, please execute the following steps:
1. Install PT8.50, and the PT8.50.xx product patch.
2. Install Enterprise Portal 9.1 as outlined in 887852.1 - PeopleSoft Enterprise Portal 9.1 Installation Guide
3. Complete the installation as outlined in the PT8.50 Installation Guide and the Enterprise Portal 9.1 Installation Guide.
4. Test the PIA signon.

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Updated on 4 December 2009Update IDs 810689 & 811680 are now available and are required for upgrading an Enterprise Portal 9 system to PeopleTools 8.50 :
1. Navigate to Patches and Updates in My Support Portal
2. In the Search For field, put 810689
3. Select Portal Solutions for the Product Line.
4. Select Enterprise Portal for the Product
5. Select 9 for the Release
6. Select the Arrow to complete the search next to the "Search For" box.
7. Click on the Update ID 810689 and you can download the Change Packager: https://psft-updates.oracle.com/ice/Resolutions/810689/upd810689.zip
8. Repeat Steps 1-7 for ID 811680
9. Apply both patches which are required for the 8.50 Tools Only upgrade to Enterprise Portal 9.